Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 15, 2024 - 02:00 GMT
Scheduled
Date: 14 November 2024
Mastercard teams will perform planned maintenance for the Event Notifications.
Impact Description: During the maintenance window, customers may experience an intermittent delay in Event Notifications for InControl for Commercial Payments (ICCP). There will be no impact on Virtual Card Number (VCN) create, update, and delete requests during this impact window.
You can learn more about Support Case Management in this training video and follow these guides to learn more about the Mastercard Connect sign-up process.
Posted Nov 14, 2024 - 16:33 GMT
This scheduled maintenance affected: Banking Partners (Bank of America, Barclaycard, Bradesco, Citi Bank, Corpay (Comdata), Commonwealth Bank of Australia, HSBC, Lloyds, RBS, Santander, Silicon Valley Bank, US Bank, JP Morgan, Bank of the West, Bank of Montreal).