Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 22, 2024 - 01:00 BST
Scheduled
Dear Client,
Our card processing partner Thredd (GPS) has informed us that they will be conducting two scheduled maintenances on Saturday 21st September 2024 from 16:00 and 18:00 GMT and Sunday 22nd September 2024 from 01:00 to 03:00 GMT.
There will be intermittent unavailability across all services during these times.
We apologise for any impact this may have on your operations.
Best regards, Nium Client Experience team
Posted Aug 23, 2024 - 01:01 BST
This scheduled maintenance affected: Banking Partners (Ixaris/Nium).