Hotel Booker Migration To Sabre

Scheduled for Mar 28, 20:00 GMT  -  Mar 29, 11:00 GMT

Update

Hotel Booker is now serviced and maintained by Sabre – please send support tickets to hotelbooker.support@sabre.com, with the following information and a member of the team will be happy to assist:

Description:
Specific details of issue:
Impact:
Screenshots (where applicable):
Posted 10 days ago. Mar 29, 2025 - 11:41 GMT

Scheduled

From 08:00 GMT on Saturday 29th March Hotel Booker will be serviced and maintained by Sabre.

You can continue to raise support tickets via ServiceNow until 20:00 GMT on Friday 28th March, after this time please send support tickets to hotelbooker.support@sabre.com, with the following information and a member of the team will be happy to assist:

· Description:

· Specific details of issue:

· Impact:

· Screenshots (where applicable):
Posted 15 days ago. Mar 24, 2025 - 16:47 GMT
This scheduled maintenance affects: Hotel Booker (Hotel Booker, Hotel Booker (mobile), Hotel Booker Reports).