Premier Inn Booking Outage
Incident Report for Conferma
Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 07:43 GMT
Investigating
Premier Inn have made us aware that their payment provider is currently experiencing an outage; which unfortunately means that bookings cannot be completed with them at this time.

Their teams are working with the provider to get the issue resolved as quickly as possible.

They apologise for any inconvenience caused.
Posted Nov 06, 2024 - 13:47 GMT
This incident affected: Hotel Booker (Hotel Booker).