Transaction File Import Delays

Incident Report for Conferma

Resolved

Transaction Import delay has now been resolved.

We apologise for the inconvenience and thank you for your patience.
Posted May 05, 2026 - 20:32 BST

Investigating

We are currently experiencing a delay in the processing of imported transaction data files.

Our teams are actively investigating and working to restore normal processing.

We apologise for any inconvenience this may cause and will provide a further update once processing has completed.
Posted May 05, 2026 - 08:10 BST