ServiceNow degraded performance
Incident Report for Conferma
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 10:30 BST
Investigating
Conferma are currently experiencing an issue within the ServiceNow portal, users may experience agents requesting further information on cases which have already been provided.

Issue : Case Details are not being displayed for our Service Desk agents.

Our technical teams have raised this with ServiceNow support to have this investigated as a matter of urgency.
Posted Apr 22, 2024 - 16:37 BST
This incident affected: Conferma HQ (Conferma Helpdesk).